summaryrefslogtreecommitdiff
path: root/tools/d2c/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/d2c/Makefile.am')
-rw-r--r--tools/d2c/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/tools/d2c/Makefile.am b/tools/d2c/Makefile.am
index 5b9eb48..c07e16f 100644
--- a/tools/d2c/Makefile.am
+++ b/tools/d2c/Makefile.am
@@ -22,26 +22,34 @@ bin_PROGRAMS = d2c
d2c_SOURCES = \
coder.h coder.c \
- tokens.l \
- grammar.y \
+ d2c.c \
+ decl.h \
+ encoding.h encoding.c \
helpers.h helpers.c \
manual.h \
pproc.h pproc.c \
qckcall.h qckcall.c \
- spec.h spec.c
+ syntax.h syntax.c \
+ tokens.l \
+ grammar.y
# _GNU_SOURCE : asprintf
d2c_CFLAGS = -D_GNU_SOURCE
d2c_LDADD = \
+ assert/libd2cassert.la \
bits/libd2cbits.la \
conv/libd2cconv.la \
+ desc/libd2cdesc.la \
format/libd2cformat.la \
hooks/libd2chooks.la \
+ id/libd2cid.la \
+ pattern/libd2cpattern.la \
rules/libd2crules.la \
- syntax/libd2csyntax.la \
args/libd2cargs.la
+d2c_LDFLAGS = -lm
+
# Automake fait les choses à moitié
CLEANFILES = grammar.h grammar.c grammar.output tokens.c tokens.h
@@ -51,4 +59,4 @@ CLEANFILES = grammar.h grammar.c grammar.output tokens.c tokens.h
EXTRA_DIST = tokens.h d2c_genmakefile.sh
-SUBDIRS = args bits conv format hooks rules syntax
+SUBDIRS = args assert bits conv desc format hooks id pattern rules