summaryrefslogtreecommitdiff
path: root/plugins/govm/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-11-18 22:56:59 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-11-18 22:56:59 (GMT)
commit26d75963fba34d8e5a5b9a6186604110552f3a38 (patch)
tree96c227003d0a1c8f71d2378d8e4477b963909708 /plugins/govm/Makefile.am
parent51e5dac69a78930fb05ccd8d9cfe59b9cd51c03a (diff)
Provided a small assembler for the GoVM architecture.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@136 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'plugins/govm/Makefile.am')
-rw-r--r--plugins/govm/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/plugins/govm/Makefile.am b/plugins/govm/Makefile.am
new file mode 100644
index 0000000..7d3e212
--- /dev/null
+++ b/plugins/govm/Makefile.am
@@ -0,0 +1,43 @@
+
+BUILT_SOURCES = gram.h
+
+AM_YFLAGS = -d
+
+lib_LTLIBRARIES = libarchgovm.la
+
+bin_PROGRAMS = goas
+
+
+#--- liboidadisas
+
+libarchgovm_la_SOURCES = \
+ instruction.h instruction.c
+
+libarchgovm_la_LDFLAGS =
+
+libarchgovm_la_LIBADD =
+
+
+#--- goas
+
+goas_SOURCES = \
+ build.h build.c \
+ goas.c \
+ gram.y \
+ tok.l
+
+
+INCLUDES =
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+goas_LDFLAGS = -L.libs
+
+goas_LDADD = $(LIBINTL) -larchgovm
+
+
+# Automake fait les choses à moitié
+CLEANFILES = gram.h gram.c tok.c