summaryrefslogtreecommitdiff
path: root/plugins/readdex/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-03-13 14:22:15 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-03-13 14:24:36 (GMT)
commitbde67ccf58fc858d5d0db4929db149ea12f50f96 (patch)
tree665c778e15b65b615410564a3bd7c83f53810b17 /plugins/readdex/Makefile.am
parentda22d42c9644de808dfc3484352c444ee4176bee (diff)
Created a readelf-like information provider for Dex files.
Diffstat (limited to 'plugins/readdex/Makefile.am')
-rw-r--r--plugins/readdex/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/plugins/readdex/Makefile.am b/plugins/readdex/Makefile.am
new file mode 100644
index 0000000..ce98d4a
--- /dev/null
+++ b/plugins/readdex/Makefile.am
@@ -0,0 +1,16 @@
+
+lib_LTLIBRARIES = libreaddex.la
+
+libreaddex_la_SOURCES = \
+ class.h class.c \
+ code.h code.c \
+ header.h header.c \
+ ids.h ids.c \
+ reader.h reader.c
+
+libreaddex_la_CFLAGS = $(AM_CFLAGS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I../../src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)