summaryrefslogtreecommitdiff
path: root/plugins/readelf/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2015-03-28 01:00:33 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2015-03-28 01:00:33 (GMT)
commit057cee1c3c109639af8f30e39e00f4884a353f31 (patch)
tree563972accde653fd562305424cb1983617bc0b4c /plugins/readelf/Makefile.am
parenta6bedf6104ccd7d8050e9d6a58f32c0827e3383c (diff)
Provided readelf features as an external plugin.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@495 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'plugins/readelf/Makefile.am')
-rw-r--r--plugins/readelf/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugins/readelf/Makefile.am b/plugins/readelf/Makefile.am
new file mode 100644
index 0000000..f6b3d5e
--- /dev/null
+++ b/plugins/readelf/Makefile.am
@@ -0,0 +1,15 @@
+
+lib_LTLIBRARIES = libreadelf.la
+
+libreadelf_la_SOURCES = \
+ header.h header.c \
+ program.h program.c \
+ reader.h reader.c \
+ section.h section.c
+
+libreadelf_la_CFLAGS = $(AM_CFLAGS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I../../src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)