summaryrefslogtreecommitdiff
path: root/plugins/readelf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readelf/Makefile.am')
-rw-r--r--plugins/readelf/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugins/readelf/Makefile.am b/plugins/readelf/Makefile.am
new file mode 100644
index 0000000..f6b3d5e
--- /dev/null
+++ b/plugins/readelf/Makefile.am
@@ -0,0 +1,15 @@
+
+lib_LTLIBRARIES = libreadelf.la
+
+libreadelf_la_SOURCES = \
+ header.h header.c \
+ program.h program.c \
+ reader.h reader.c \
+ section.h section.c
+
+libreadelf_la_CFLAGS = $(AM_CFLAGS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I../../src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)