summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-04-25 16:51:41 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-04-25 16:51:41 (GMT)
commitb9977e00ff9eb6e025e86a15c858183f3f314cf5 (patch)
treeeedacb236b90228d2b4c603fa9875ecaad05ee29 /src/Makefile.am
parent216a3d0121fabd678e50ea6b4fa2447ae9b921f0 (diff)
Saved the current work on plugins.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@59 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am37
1 files changed, 20 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da52127..fa63b43 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,43 +2,46 @@
bin_PROGRAMS=openida
openida_SOURCES = \
- binary.h binary.c \
dlg_sections.h dlg_sections.c \
- easygtk.h easygtk.c \
editor.c \
pan_strings.h pan_strings.c \
pan_symbols.h pan_symbols.c \
project.h project.c \
- support.h support.c \
+ shell.h shell.c \
xdg.h xdg.c \
xml.h xml.c
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/intl $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) `pkg-config --cflags gthread-2.0`
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/intl $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) `pkg-config --cflags gthread-2.0` $(LIBPYTHON_CFLAGS) $(LIBVTE_CFLAGS)
AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-openida_LDFLAGS = $(LIBGTK_LIBS) -L/usr/X11R6/lib -ldl -lm $(LIBXML_LIBS) `pkg-config --libs gthread-2.0`
+openida_LDFLAGS = $(LIBGTK_LIBS) -L/usr/X11R6/lib -ldl -lm $(LIBXML_LIBS) `pkg-config --libs gthread-2.0` $(LIBPYTHON_LIBS) $(LIBVTE_LIBS) \
+ -Larch/.libs -larch \
+ -Lcommon/.libs -lcommon \
+ -Lpanel/.libs -lpanel \
+ -Lgtkext/.libs -lgtkext \
+ -Lanalysis/.libs -lanalysis \
+ -Lformat/.libs -lformat \
+ -Lformat/dwarf/.libs -lformatdwarf \
+ -Lformat/elf/.libs -lformatelf \
+ -Lformat/java/.libs -lformatjava \
+ -Lformat/mangling/.libs -lformatmangling \
+ -Lformat/pe/.libs -lformatpe
openida_LDADD = $(LIBINTL) \
- arch/libarch.a \
- arch/x86/libarchx86.a \
debug/libdebug.a \
debug/ptrace/libdebugptrace.a \
- format/libformat.a \
- format/dwarf/libformatdwarf.a \
- format/elf/libformatelf.a \
- format/java/libformatjava.a \
- format/mangling/libformatmangling.a \
- format/pe/libformatpe.a \
- gtkext/libgtkext.a \
- panel/libpanel.a \
- analysis/libanalysis.a \
+ plugins/libplugins.a \
+ plugins/pyoida/libpyoida.a \
common/libcommon.a
-SUBDIRS = analysis arch common debug format gtkext panel
+# gtkext doit être traité en premier, à cause des marshals GLib
+# common doit être passé avant analysis
+
+SUBDIRS = arch format common analysis debug gtkext panel plugins