summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-06-30 20:24:59 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-06-30 20:24:59 (GMT)
commitdde6bbf77e6a6df95dad5426e56a4bba115a7253 (patch)
treee7eebe20118143e901472b07b55ca3d59e2a65ab /src/arch/x86/Makefile.am
parent2c9fa2bc584305985ae53958ea2fb371adba3834 (diff)
Added a few extra opcodes: imul, jle, movsx and movzx.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@85 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index 4b4222a..257bf9c 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -17,6 +17,8 @@ libarchx86_la_SOURCES = \
op_lea.c \
op_leave.c \
op_mov.c \
+ op_movsx.c \
+ op_movzx.c \
op_mul.c \
op_nop.c \
op_not.c \
@@ -42,8 +44,6 @@ libarchx86_la_SOURCES = \
processor.h processor.c \
registers.h registers.c
-# op_movsx.c
-# op_movzx.c
libarchx86_la_CFLAGS = $(AM_CFLAGS)