summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-08-09 18:12:27 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-08-09 18:12:27 (GMT)
commit5cd25c4adfe0426520a51a76de3f77c77cfa4b8e (patch)
tree396514971fb78e81b7bb55c9cd3331d87b45ca9a /src/format/Makefile.am
parentd02deb2425d6559c357bdd00e1c0fb05f35d5fc9 (diff)
Reorganized the way formats are handled (Java and PE got disabled, Dwarf is empty).
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@105 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am35
1 files changed, 27 insertions, 8 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index 92a774b..9bfdd92 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -2,17 +2,35 @@
noinst_LTLIBRARIES = libformat.la
libformat_la_SOURCES = \
- exe_format.h exe_format.c \
- exe_format-int.h \
- dbg_format.h dbg_format.c \
- dbg_format-int.h
+ executable-int.h \
+ executable.h executable.c \
+ format-int.h \
+ format.h format.c \
+ part.h part.c \
+ symbol.h symbol.c
+
+# libformat_la_SOURCES = \
+# exe_format.h exe_format.c \
+# exe_format-int.h \
+# executable-int.h \
+# executable.h executable.c \
+# format-int.h \
+# format.h format.c \
+# dbg_format.h dbg_format.c \
+# dbg_format-int.h \
+# part.h part.c
libformat_la_LIBADD = \
dwarf/libformatdwarf.la \
elf/libformatelf.la \
- java/libformatjava.la \
- mangling/libformatmangling.la \
- pe/libformatpe.la
+ mangling/libformatmangling.la
+
+# libformat_la_LIBADD = \
+# dwarf/libformatdwarf.la \
+# elf/libformatelf.la \
+# java/libformatjava.la \
+# mangling/libformatmangling.la \
+# pe/libformatpe.la
libformat_la_LDFLAGS =
@@ -23,4 +41,5 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS = dwarf elf java mangling pe
+SUBDIRS = dwarf elf mangling
+#SUBDIRS = dwarf elf java mangling pe