summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am35
1 files changed, 27 insertions, 8 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index 92a774b..9bfdd92 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -2,17 +2,35 @@
noinst_LTLIBRARIES = libformat.la
libformat_la_SOURCES = \
- exe_format.h exe_format.c \
- exe_format-int.h \
- dbg_format.h dbg_format.c \
- dbg_format-int.h
+ executable-int.h \
+ executable.h executable.c \
+ format-int.h \
+ format.h format.c \
+ part.h part.c \
+ symbol.h symbol.c
+
+# libformat_la_SOURCES = \
+# exe_format.h exe_format.c \
+# exe_format-int.h \
+# executable-int.h \
+# executable.h executable.c \
+# format-int.h \
+# format.h format.c \
+# dbg_format.h dbg_format.c \
+# dbg_format-int.h \
+# part.h part.c
libformat_la_LIBADD = \
dwarf/libformatdwarf.la \
elf/libformatelf.la \
- java/libformatjava.la \
- mangling/libformatmangling.la \
- pe/libformatpe.la
+ mangling/libformatmangling.la
+
+# libformat_la_LIBADD = \
+# dwarf/libformatdwarf.la \
+# elf/libformatelf.la \
+# java/libformatjava.la \
+# mangling/libformatmangling.la \
+# pe/libformatpe.la
libformat_la_LDFLAGS =
@@ -23,4 +41,5 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS = dwarf elf java mangling pe
+SUBDIRS = dwarf elf mangling
+#SUBDIRS = dwarf elf java mangling pe