summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-05-11 23:42:48 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-05-11 23:42:48 (GMT)
commit96cb6971ee3ca529958b8cb1e8e55a6eb4e60eae (patch)
tree68e49f325de3e93ef186d3e078da8ddc473aedf7 /src/format/Makefile.am
parent80dc0ac97987ad9246bee7c47458a015339453bf (diff)
Reorganized the way the program is built again and added partial support for the JVM.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@63 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index cad15c5..92a774b 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -1,5 +1,5 @@
-lib_LTLIBRARIES = libformat.la
+noinst_LTLIBRARIES = libformat.la
libformat_la_SOURCES = \
exe_format.h exe_format.c \
@@ -7,6 +7,13 @@ libformat_la_SOURCES = \
dbg_format.h dbg_format.c \
dbg_format-int.h
+libformat_la_LIBADD = \
+ dwarf/libformatdwarf.la \
+ elf/libformatelf.la \
+ java/libformatjava.la \
+ mangling/libformatmangling.la \
+ pe/libformatpe.la
+
libformat_la_LDFLAGS =