summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index cad15c5..92a774b 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -1,5 +1,5 @@
-lib_LTLIBRARIES = libformat.la
+noinst_LTLIBRARIES = libformat.la
libformat_la_SOURCES = \
exe_format.h exe_format.c \
@@ -7,6 +7,13 @@ libformat_la_SOURCES = \
dbg_format.h dbg_format.c \
dbg_format-int.h
+libformat_la_LIBADD = \
+ dwarf/libformatdwarf.la \
+ elf/libformatelf.la \
+ java/libformatjava.la \
+ mangling/libformatmangling.la \
+ pe/libformatpe.la
+
libformat_la_LDFLAGS =