summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-04-25 16:51:41 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-04-25 16:51:41 (GMT)
commitb9977e00ff9eb6e025e86a15c858183f3f314cf5 (patch)
treeeedacb236b90228d2b4c603fa9875ecaad05ee29 /src/format/Makefile.am
parent216a3d0121fabd678e50ea6b4fa2447ae9b921f0 (diff)
Saved the current work on plugins.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@59 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index baf11de..41d7120 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -1,13 +1,18 @@
-lib_LIBRARIES = libformat.a
+lib_LTLIBRARIES = libformat.la
-libformat_a_SOURCES = \
+libformat_la_SOURCES = \
exe_format.h exe_format.c \
exe_format-int.h \
dbg_format.h dbg_format.c \
dbg_format-int.h
-libformat_a_CFLAGS = $(AM_CFLAGS)
+libformat_la_LDFLAGS = $(LIBGTK_LIBS) \
+ -Ldwarf/.libs -lformatdwarf \
+ -Lelf/.libs -lformatelf \
+ -Ljava/.libs -lformatjava \
+ -Lmangling/.libs -lformatmangling \
+ -Lpe/.libs -lformatpe
INCLUDES = $(LIBGTK_CFLAGS)