summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index baf11de..41d7120 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -1,13 +1,18 @@
-lib_LIBRARIES = libformat.a
+lib_LTLIBRARIES = libformat.la
-libformat_a_SOURCES = \
+libformat_la_SOURCES = \
exe_format.h exe_format.c \
exe_format-int.h \
dbg_format.h dbg_format.c \
dbg_format-int.h
-libformat_a_CFLAGS = $(AM_CFLAGS)
+libformat_la_LDFLAGS = $(LIBGTK_LIBS) \
+ -Ldwarf/.libs -lformatdwarf \
+ -Lelf/.libs -lformatelf \
+ -Ljava/.libs -lformatjava \
+ -Lmangling/.libs -lformatmangling \
+ -Lpe/.libs -lformatpe
INCLUDES = $(LIBGTK_CFLAGS)